Author Topic: Installing modkit and needed other files  (Read 1216 times)

0 Members and 1 Guest are viewing this topic.

Offline galensgranny

  • Architect
  • *****
  • Posts: 728
  • Country: us
Installing modkit and needed other files
« on: September 05, 2017, 10:57:21 PM »
I thought to at least install the modkit and see if I could figure out anything about modding.  I have a question right from the basic beginning.  The instructions say to Install Visual Studio 2012 Redist.   When I go to the page to do that, there are three choices.  https://www.microsoft.com/en-us/download/details.aspx?id=30679 :

Version:2012.4File Name:VSU_4\vcredist_x64.exe
VSU_4\vcredist_x86.exe
VSU4\vcredist_arm.exe

Which one do I download?

Offline kid1293

  • Modders
  • Banished Expert
  • *****
  • Posts: 2893
  • Country: se
  • Never confuse movement with progress
Re: Installing modkit and needed other files
« Reply #1 on: September 06, 2017, 01:22:45 AM »
vcredist_x64 if your windows is 64-bit (newer computer)
vcredist_x86 if your windows is 32-bit (older, less memory)
don't take the third!

Offline galensgranny

  • Architect
  • *****
  • Posts: 728
  • Country: us
Re: Installing modkit and needed other files
« Reply #2 on: September 07, 2017, 12:54:23 AM »
Thanks, Kid!

Offline Hawk

  • Architect
  • *****
  • Posts: 535
  • Country: us
Re: Installing modkit and needed other files
« Reply #3 on: December 31, 2017, 05:42:01 PM »
I realize this is an older topic but my question is kind of relevant to this discussion, so I figured it would be better to ask it here rather than start a new topic.

The instructions for the ModKit say to download The DirectX End User Runtime. Wouldn't that be the same thing that Windows installs by default? I have Win 7 64-bit and it installed DX 11.
It also says to install The Visual Studio 2012 Redist. I have Microsoft Visual C++ 2013 Redistributable (x64) - 12.0.21005 already installed. Do I still need to download and install the older version? I also have the 32-bit version of the above installed.
Hawk

Yes, I can multitask. I can listen, ignore and forget all at the same time.

Offline Discrepancy

  • Modders
  • Architect
  • *****
  • Posts: 928
  • Country: au
Re: Installing modkit and needed other files
« Reply #4 on: December 31, 2017, 05:46:26 PM »
my experience is sometimes yes you need the earlier ones too. Try it first and see, it will give you a fault as soon as you try to run the 'BuildResources.bat'.

Offline Hawk

  • Architect
  • *****
  • Posts: 535
  • Country: us
Re: Installing modkit and needed other files
« Reply #5 on: December 31, 2017, 06:06:53 PM »
I'm guessing you're talking about the VS Redist, but does that also apply to the DX End User thing? Isn't that just DX installed by Windows, or is the link in the read me linked to an earlier version of that too?
I didn't think you could have DX 9 and DX 11 both installed.
Hawk

Yes, I can multitask. I can listen, ignore and forget all at the same time.

Offline Discrepancy

  • Modders
  • Architect
  • *****
  • Posts: 928
  • Country: au
Re: Installing modkit and needed other files
« Reply #6 on: December 31, 2017, 06:25:40 PM »
yes the earlier VS versions. I think you are right about DX11 and 9, with DX11 you already have DX9 api's included, so you shouldn't need both.

Offline Hawk

  • Architect
  • *****
  • Posts: 535
  • Country: us
Re: Installing modkit and needed other files
« Reply #7 on: December 31, 2017, 06:31:04 PM »
OK! Thanks @Discrepancy  :)
Hawk

Yes, I can multitask. I can listen, ignore and forget all at the same time.