Author Topic: Getting IO\MemoryStream.cpp(75) error when packaging.  (Read 381 times)

0 Members and 1 Guest are viewing this topic.

Offline Tawsag

  • Newb
  • *
  • Posts: 7
Re: Getting IO\MemoryStream.cpp(75) error when packaging.
« Reply #15 on: September 12, 2017, 10:17:27 AM »
Ok, a quick update, and answer to Red's questions.

First, yes I always delete the bin and Build folders before a new build.  I learned a long time ago when working with mod kits of any form, to delete previous builds and not overwrite.

About the added livestock and wild animals.  I got some of the meshes and textures from free 3d model sites, and did all the rigging and animations myself.  There was a lot of trial and error to get them to work correctly in the game.  About the LivestockFriesianCow, it's just a logical name to call it, and purely coincidental.


About the I/O error.

After cleaning out pretty much everything in the banMyWay folder.   I got it to build, and package into approximately 57Mb .pkm.  It will run in the /onlypkg command, but there are some inconsistencies with the /ref play through.  So, I'm about to rebuild the entire mod one part at a time, to find the problems.

Good news, is I'm making progress.

Again, thank you Red, for your help!

Offline RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7384
Re: Getting IO\MemoryStream.cpp(75) error when packaging.
« Reply #16 on: September 12, 2017, 11:48:04 AM »
Ok, a quick update, and answer to Red's questions.

First, yes I always delete the bin and Build folders before a new build.  I learned a long time ago when working with mod kits of any form, to delete previous builds and not overwrite.

About the added livestock and wild animals.  I got some of the meshes and textures from free 3d model sites, and did all the rigging and animations myself.  There was a lot of trial and error to get them to work correctly in the game.  About the LivestockFriesianCow, it's just a logical name to call it, and purely coincidental.

great !
should do a tuto one of these days :)

About the I/O error.

After cleaning out pretty much everything in the banMyWay folder.   I got it to build, and package into approximately 57Mb .pkm.  It will run in the /onlypkg command, but there are some inconsistencies with the /ref play through.  So, I'm about to rebuild the entire mod one part at a time, to find the problems.

Good news, is I'm making progress.

Again, thank you Red, for your help!

good :)

btw, i never never build and check in sandbox mode... i always go live everytime each time i want to check changes !
the sandbox mode is too far from reality, from live. and you end up to sometime lose time for nothing searching errors you shouldnt have / not seeing the errors you'll get once you try it live.

you should get the habit to launch your game live when you want to test changes/test to see if it works.
and put the /ref in the garbage.

reinstall your toolkit to refresh your real toolkit files in case you deleted one / or made some changes in the wrong copy of files (edited the original instead of your mod files)

will hope to see good news from you on your mod :)
seems very exciting.

> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.