Author Topic: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)  (Read 844 times)

0 Members and 1 Guest are viewing this topic.

Offline CuroAmarSalus

  • Newb
  • *
  • Posts: 2
Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« on: May 01, 2017, 04:23:25 PM »
Hi,

Just joined this forum after about an hour of testing and searching.

While running "BuildResources.bat" as described in the readme.html file, Tools-x64.exe will "stop working" as Windows describes it. I've tried reinstalling and checking all my versions of the Visual C++ Redists, to no luck. I tried searching the forums here looking for a previous thread, but no luck there as well.


I get to here:
Code: [Select]
D:\Banished Kit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc
SRS Toolset version 1.0.6 Build 160521
Compiling 'Dialog\Loading.rsc:resource'
Compiling 'Dialog\Loading.rsc:main'
Compiling 'Dialog\Loading.rsc:fullContent'
Compiling 'Dialog\Loading.rsc:content'
Compiling 'Dialog\Loading.rsc:imageGroup'
Compiling 'Dialog\Loading.rsc:animatedImage'
Compiling 'Dialog\LoadingSpriteSheet.rsc:resource'
Compiling 'Dialog\LoadingSpriteSheetMaterial.rsc:resource'
Compiling 'Material\UI\uiMaterial.rsc:resource'
Compiling 'Material\UI\uiMaterial.rsc:normal'
Compiling 'Material\UI\UI.srsl:Normal_vs'

And then the standard error:
"Tools-x64.exe has stopped working
A problem caused the program to stop working correctly.
Windows will close the program and notify you if a solution is available."


If I close that and let the batch file continue to run the code, it will continue to violently explode every time it (Tools-x64.exe) is called.

I've tried going to the 1.0.7 modkit with the beta game files and that did not work as well- same error.

At this point, I'm quite frustrated. Did I miss something obvious? I couldn't find anything in the readme.

Is this related to the DirectX SDKs, which will not install on my machine? (Is there a specific version of the DirectX SDKs that I must use?)

Edit: Fixed grammatical errors and typos.
« Last Edit: May 01, 2017, 04:33:17 PM by CuroAmarSalus »

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #1 on: May 01, 2017, 09:39:57 PM »
first, try to change your folder name. the tools kit doesnt like any spaces or strange caracters.

and yes you absolutely need direct x sdk.
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline CuroAmarSalus

  • Newb
  • *
  • Posts: 2
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #2 on: May 09, 2017, 10:28:04 AM »
Hi RedKetchup,

Thanks for your reply. I changed the path to the Banished Kit so that it does not include any spaces or special symbols. I also managed to get the DirectX SDK installed.

It still crashes in the same manner.

Offline embx61

  • Modders
  • Banished Expert
  • *****
  • Posts: 1290
  • You are always on my mind, Forever in my heart
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #3 on: May 09, 2017, 10:53:44 AM »
@CuroAmarSalus

D:\Banished Kit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc.

The > character should be a \ character in your code.
My beloved Kathy
As you were you will always be
Treasured forever in my memory

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #4 on: May 09, 2017, 01:31:37 PM »
the > is his DOS prompt :)
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #5 on: May 09, 2017, 01:36:36 PM »
did you made a copy of data0.pkg, data1.pkg (and patch0.pkg, patch1.pkg) to your modkit/bin/WinData folder ?
and these datas are from 1.0.6 ? same version of your toolkit ?

if nothing work, i can maybe pm you for a tempary solution that i cant explain here.
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline DeFrank

  • Newb
  • *
  • Posts: 9
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #6 on: June 12, 2017, 10:34:50 AM »
I'm having this exact same issue. Ever get to the bottom of it?

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #7 on: June 12, 2017, 11:47:03 AM »
can we have some screenshots of your modkit installation, @DeFrank  ?
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline DeFrank

  • Newb
  • *
  • Posts: 9
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #8 on: June 12, 2017, 12:21:13 PM »
Here is a treeview of the installation: https://drive.google.com/open?id=0B6S_4lJSl8WJRkJCcEpxZmxlMlE

http://i.imgur.com/PHvVXRO.png
Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)


Let me know if you need anything else.

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #9 on: June 12, 2017, 12:25:52 PM »
hmmmm looks like it probably something about your video/directX

do you have a recent video card ?
is your directX End User installed ? (end user is different than the common one) http://www.microsoft.com/en-us/download/details.aspx?id=35

did you downloaded the other file ? visual studio? http://www.microsoft.com/en-us/download/details.aspx?id=30679
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline DeFrank

  • Newb
  • *
  • Posts: 9
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #10 on: June 12, 2017, 12:30:49 PM »
When I install DirectX setup the installer says that a newer or equivalent version of DirectX has been installed already. The second link is a 404.

I have a Radeon R7 370 GPU.
« Last Edit: June 12, 2017, 12:42:11 PM by DeFrank »

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #11 on: June 12, 2017, 12:46:52 PM »
you probably have windows 10 ?

download it, download your real one for windows 10. install the lower one and reinstall ontop of it your real one after.
(just to make sure you have everything from the lowest one that maybe hasnt been included with your new one)
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline DeFrank

  • Newb
  • *
  • Posts: 9
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #12 on: June 12, 2017, 12:54:28 PM »
Thanks again for your help. Yes, I do have Windows 10.

Not sure what the "it" is you are referring to. The first link (directX) I downloaded and installed. After the installation is when it tells me that I have a newer or equivalent already installed so my only option is to click Finish.

The second link is going to a 404. Do you have an alternate location for it?

Online RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 7273
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #13 on: June 12, 2017, 12:58:25 PM »
seems they dont offer the 2012 anymore :S

they offer a 2015 though
https://www.microsoft.com/en-us/download/details.aspx?id=52685

maybe i still have a 2012 somewhere on my PC.....


(about the "it" i referred to the http://www.microsoft.com/en-us/download/details.aspx?id=35)
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline DeFrank

  • Newb
  • *
  • Posts: 9
Re: Tools-x64 Stopped Working (Modkit 1.0.6/1.0.7)
« Reply #14 on: June 12, 2017, 01:02:00 PM »
Yeah I downloaded every redist I could find. Looks like I'm stuck.  :(