Author Topic: 1.06 to 1.07 changes. WILL OLD MODS WORK?????  (Read 299 times)

0 Members and 1 Guest are viewing this topic.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 2599
  • Country: us
1.06 to 1.07 changes. WILL OLD MODS WORK?????
« on: November 18, 2017, 12:36:44 PM »
        fine print: please note banished is a computer program as such there is exceptions as comupters have minds of thier own at times.

       since the upgrade to 1.07,this has come up many times. i will try to explain it and hopefully don't confuse anyone more. let's start with the timeline.
   2 things happened at almost the same time. these changes< plural> sent modders upgrading most of the mods they had already made and posted.there are however,many modders who by now had moved on from the game. hence,we have 1.06 mods that can not be upgraded,upgraded to 1.07 mods,and mods in process of being upgraded. we also have mods being split into different parts whereby what was 1 mod before can now be several smaller mods. these 2 changes have made the game better but also have brought some confusions.
     change 1> LUKE,the game designer, released an upgrade with more limit flags. this i will go through in depth.
    change 2> NECORA cracked the game code so that modders could have their own icon on the toolbar. before the game put houses with houses, storage with storage,etc. there were exceptions and the game then would add themed sets to the main toolbar.this made the toolbar longer.now a modder has his or her mods under 1 icon. on the main toolbar is a community icon that the modder's icons go under. clicking on the community icon will lead you to a toolbar with icons for KID,RED,EB,DS,CC,NECORA,etc. this change made the main toolbar shorter,organized the mods better,and reminds you of which modder made each mod. due to this change mods were upgraded regardless of the 1.07 limit flags. even if the new 1.07 had no affect, many mods were upgraded to use the community icon option. this is an important point. a plain house mod that does not use the 1.07 flags could be upgraded.the 1.06 version of the same house would work the same. the only difference between the 2 mods would be where the game places it in the toolbars.
     modders can beat me with a stick for this, but i will say it anyhow in hopes that it helps explain things better. there are times where it is not neccessary to upgrade a mod. i have several mods that i left at 1.06 and chose not to upgrade. why? because i am used to where they are in the toolbar.
if the upgrade did nothing more than move the mod from where it was to the community icon,i left the old mod alone. NOTE: if you do this with a storage mod,be aware that the old modded stoage will not store the new items. example: an old barn or market will not store RED's fodder or fertilizer.

OLD LIMIT FLAGS: logs,stone,iron,fuel,tools,food,herbs,clothes,alcohol, and coal.
        most 1.06 mods use these tags. exceptions: CC uses these tags but for more items. a 1.06 version CC will place lumber,furnace fuel,etc under these tags.THE NORTH is known to change the iron to iron bloom. a 1.06 storage or market mod will still store these tags but will not store anything under different tags.so if coal is changed to mineral with the new flags,it will no longer store as coal.what we see an item as can be different than what the program reads it as.we see firewood the game reads fuel.

NEW LIMIT FLAGS:logs,stone,iron,fuel,tools,food,herbs,clothing, <so far same as the old way. any mod that uses this list and nothing more will work as it did before.any 1.06 storage mod will still store these items.>
  new limit flags added:textiles,minerals,crafted,forged,fabrics,industrial,materials,construction,precious,and misc.   these items will not store or work in 1.06 buildings. charcoal from a 1.07 mod will not work as charcoal to a 1.06 modded building. also if you processed charcoal from a 1.06 mod it will not work for a 1.07 modded building either.
                these differences do not break the game and cause it to not function, unless you try using a 1.07 mod in a 1.06 game. a 1.06 mod added to a 1.07 game still functions as it did before and will store and use items as it did before.

    KNOWN ISSUES: there are trading post issues where the merchant comes with 1.07 tagged items to a 1.06 TP.
MOD LOAD: http://worldofbanished.com/index.php?action=downloads;sa=view;down=280

this compatability mod fixes issues between CC and RED's NMT.it bridges 1.06 and 1.07 differences of brick,clay,roof tiles,etc. it fixes it so several items can be used and stored between the 2.  this mod was made to work with the MEGAMOD version of CC,as such it should fix issues with more individual mods. it will not fix all storage differences or solve all issues. my theory is if it helps something use it. it is better to have it and not need it than to crash because you don't have it.
MOD LOAD: http://blackliquidsoftware.com/index.php?/files/file/167-107-compatibility-for-megamod-007/
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
       most 1.06 mods will work in a 1.07 game.there are very very few exceptions. the only issue i know of is when trying to use the NORTH mod with CC. those issues are due to the iron ore,iron bloom differences more so than the 1.07 changes. using the NORTH without the CC does work.ABANDONED has a village blog where she used the NORTH MOD after upgrading to 1.07.
      from experience the only noticeable differences or problems,though that isn't the right word, really is with storage. there is a learning curve to the storage differences.all modders have made new storage options to allow us to store the new items.the upgraded mods come with storages set to the new limits. as a player it is easy to place a barn that only stores 1.06 items and not remember you need a 1.07 storage in that area of the map. i still have markets that i use for production areas that are 1.06. as long as i remember to add more 1.07 storages as well,there is no problem. if you forget this,the vanilla pile and barn that the game starts with will fill.once the start pile fills clearing and expansion will slow down or stop.

      there are many 1.06 mods that modders have left us with. though the modders have moved on,these mods can be very useful. we don't need to throw them away and stop using them.many serve a purpose rather it be just for the texture and building style or the storage option and capacity. i srill use TOM's NORDIC mods though the barns won't store new items. SLINK's market set still gets used to move stone and logs.you just have to rememeber to build something to store thatch.the old empporium mod still stores many items near forests. there are old castles,hopitals,many many housing options,bakeries,mills,etc.
        mixing and matching buildings from 1 mod with another is what makes each banished game you play unique.every player has their own individual style and can make their own game. don't think that old mods either won't work or have no use. new players should go back through the download section and other sites as well. they will find many trinkets to help make their game better.


Offline galensgranny

  • Architect
  • *****
  • Posts: 701
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #1 on: November 18, 2017, 01:27:31 PM »
Thanks for posting this helpful explanation. brads3. 

It is good that you explained that most of the 106 mods still work fine in an updated 107 game.  After the game updated to 107, I thought older mods might not work, but they do.  So I looked back at the older mods on this site and found some things I had not downloaded to use and they work fine (houses and other buildings that had the same functions as the vanilla game).   I still use one of the versions of Red's New Medieval Town. I think I use v 1.1b .  I particularly like the style of the barns.  Even if they might not put in some of the new modder's items, I don't care since I use them in the forest for the usual vanilla items the gathers and hunters pick up.


Offline RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 9469
  • Country: ca
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #2 on: November 18, 2017, 02:32:55 PM »
there is only 1 thing about my old mods bugging in 1.0.7 : Lighthouse (crash on open)
the old mods will always working, maybe bricks wont have same flag but still working perfectly. i can maybe reverify at some point. although it is always better to overwrite on top with the 1.0.7 ones (like the NMT3.0 Clay chain)
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Online pappa

  • Laborer
  • **
  • Posts: 44
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #3 on: November 18, 2017, 03:34:09 PM »
Very good right up brads3

Offline brads3

  • Banished Expert
  • *****
  • Posts: 2599
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #4 on: November 18, 2017, 04:25:04 PM »
thx all. GRANNY, depending on the barns you mean,there may be a separate mod for them mixed in the blog pages that RED was using when he developed the NMT.  the irrelevant barns were added to the 2.04 version. i do think that has a separate mod. in the forest i like using NECORA's pine mod material barn. that barn stores logs and stone and thatch.it also has a small market to help supply tools and move the items out of the forest.
    RED,i have not noticed an error with the lighthouse other mine does bring nomads at odd spots far to the map edge at times.i think you fixed that and i am just a version behind. as to the bricks,the compatability 1.07 mod fixes those problems and with CC,i can use them and the clay back and forth across both mods.

Offline galensgranny

  • Architect
  • *****
  • Posts: 701
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #5 on: November 18, 2017, 05:06:23 PM »
Brad, thanks for telling about the separate Irrelevant's Small Barns Collection.  I found the download link at reply #24 in the thread at http://worldofbanished.com/index.php?topic=941.15 (in case anyone wants just the barns).  Those are the barns I really like from the version of Red's NMT that I have.  I use the tiny barn a lot in the woods.

I need to start reading through old threads to find hidden "gems" for download.

I do also like a great deal Necora's pine mod material barn.  At first, I had trouble using his Pine Mod due to the game slowing too much, until I got the tip to lower the shadows in the game options.  We could use some more material barns of various sizes, in the game, as separates or small sets that do not involve any change to the game.  Embx61 has one that is good, but too large for some areas where I would like one.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 2599
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #6 on: November 18, 2017, 06:46:25 PM »
there are a few markets that do that. most are 1.06. there is RED's wharehouse and EB has a 1 plus sets. for 1.06 there is the nordic wharehouse and SLINK's small market set. that has options for storing logs and stone as well as food and textiles.just remember to have a barn that stores the 1.7 items or use a pile.if you want a small barn with good capacity for food,tools,or clothing in the forest try KID's forest outpost mod.
    speaking of how good "trinkets" hide. i ran into a site with the 1:1 age mod. some how i clicked on the changelog button and it pulled up a huge list of various options WITH DOWNLOAD LINKS, for when they were fine-tuning the mod. that gave many different options a  player could go through and pick what suited them.there were at least 10 different ways to have the mod.
   glad you got the pine mod to work. have you tried ther original thatch mod/ nat div with it??

Offline galensgranny

  • Architect
  • *****
  • Posts: 701
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #7 on: November 19, 2017, 03:20:13 AM »
glad you got the pine mod to work. have you tried ther original thatch mod/ nat div with it??

No,  I haven't.  Maybe I will try those.

That was a nice surprise find for you when you found a list of options with download links.

Offline Goblin Girl

  • Trader
  • ****
  • Posts: 214
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #8 on: November 19, 2017, 06:12:46 AM »
I noticed just yesterday that the Viking Stock Vault won't store the Domestic Animal resource, which now seems to be flagged as misc.  I built a storage cellar on the side of the vault, and the problem was solved. It's weird, because I got it from the 1.07 mod section.  But, it's not game breaking, so oh well.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 2599
  • Country: us
Re: 1.06 to 1.07 changes. WILL OLD MODS WORK?????
« Reply #9 on: February 26, 2018, 06:15:45 PM »
domestic animals is from CC. they are flagged misc. there isn't much added under this tag so DS ay have left it out.it also should be left out of some mods since it does store fertilizer.you dont want that stored with your food.