Author Topic: have run the build.bat but no mod appears in game... help! :)  (Read 156 times)

0 Members and 1 Guest are viewing this topic.

Offline BlueFireChelle

  • Laborer
  • **
  • Posts: 40
  • Country: 00
me again ;)
So, I have made all the models, and am up to this part of @Discrepancy  tutorial
Quote
Now we can build the model!
Double click on the '1 Build.bat' file we created, and if all was followed it should build...
You will be prompted if there is an issue.
My build went fine,
I then double click on the 2 Run.bat file and the game loads up. Start a new game.
The model loads up fine in game, but it is too big !

My .bat file runs okay (i think) but when I load the game my mod does not appear. Where's the first spot that I should check for a problem? I have looked through the files I made and they appear to be correct. They also match the example Apiary. The only thing that I can see that is quite different is in the ModKit example folder ...BanishedModKit_1.0.7.170910\example\building\bin  (which I believe was created when running the .bat file) there are a lot more folders and some .crs files. In mine, i only have the /dialog folder and 1 resources.crs file.  (The folders for Models, Profession, Template and UI were not created on mine.)

Has the build.bat file not run correctly?

I have literally no clue what I am doing except following the tutorial.

Any advice would be really appreciated.

Offline RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 9140
  • Country: ca
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #1 on: May 29, 2018, 03:52:32 AM »

The only thing that I can see that is quite different is in the ModKit example folder ...BanishedModKit_1.0.7.170910\example\building\bin 

never do that ! never put any strange caracter. rename your kit folder to BanishedModKit\example\building\bin 
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.

Offline BlueFireChelle

  • Laborer
  • **
  • Posts: 40
  • Country: 00
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #2 on: May 29, 2018, 04:04:34 AM »
I actually just saw that comment elsewhere when someone else was having trouble. That name is the default when installing the ModKit, but I have now changed it. I have re-run the build.bat but it is not compiling.
I don't recall putting the folder location in any of the files that I changed from the Apiary example, but I am going through them all now to see...
What else might be the most likely issue? I'll keep looking.....

Offline BlueFireChelle

  • Laborer
  • **
  • Posts: 40
  • Country: 00
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #3 on: May 29, 2018, 04:07:30 AM »
The Apiary example AO file is 64x64. My AO file is not. I'm about to try changing that.

Offline BlueFireChelle

  • Laborer
  • **
  • Posts: 40
  • Country: 00
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #4 on: May 29, 2018, 04:33:06 AM »
I found a previous suggestion from Kid about deleting the /bin folder. So I did that and it compiled!
Getting closer! The Icon did not appear properly on the housing menu bar (it was a dot) and the game crashed when I clicked it. But I'm getting closer! :) i'll keep googling for help, but wanted to comment again to say that I figured the compiling bit out.
cheers

Offline BlueFireChelle

  • Laborer
  • **
  • Posts: 40
  • Country: 00
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #5 on: May 29, 2018, 05:27:18 AM »
It works!!! The Bannies moved into my house!! :)  Very cool.
(now to try again right from the beginning and make a house that looks half-decent.)

Offline kid1293

  • Modders
  • Banished Expert
  • *****
  • Posts: 2602
  • Country: se
  • Never confuse movement with progress
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #6 on: May 29, 2018, 05:35:32 AM »
Congratulations!
Now you're hooked and will only make better and better models :)

Offline RedKetchup

  • Champion
  • Banished Expert
  • *****
  • Posts: 9140
  • Country: ca
Re: have run the build.bat but no mod appears in game... help! :)
« Reply #7 on: May 29, 2018, 06:47:41 AM »
congrats !!
> > > Support Mods Creation developments with Paypal Donations < < <
Click here to PayPal Donate.