Author Topic: Compatability Question - Game Crashes  (Read 1695 times)

0 Members and 1 Guest are viewing this topic.

Offline Mikkey

  • Newb
  • *
  • Posts: 8
Compatability Question - Game Crashes
« on: January 04, 2020, 05:29:40 PM »
Hey guys,

hoping you can help me out here.

I currently use MM8 but also added a lot of other mods. I'm guessing there may be a compatibility problem somewhere, I've tried different load orders but I keep encountering the same problem and getting tired of starting new games. Thing is, everything usually starts out fine but after quite a while of playing (several hours of gaming usually) the game just keeps crashing. In my latest game I'm currently on year 76 with about 260 people. I use the RealTimeAging mod so progression is quite slow which I like.
Now the game just randomly crashes (the usual Runtime Error) a few minutes after loading it. At this point I've usually built enough buildings that it's too hard for me to pinpoint what may cause the crashes but maybe there's a known error I'm not aware of that you could point out.

Additionally to MM8 I'm using some of Necora's mods (Pine Set, Maritimes Dock Set, NS Inshore Fisheries, PEI Shore Collection, Port Royal, Maritimes Coverings, Decorations, Humble Construction, Log Cabins, Sherbrooke Village, Riffle and Storage Collection)
I also use some of Tom Sawyer's mods: Campfire, Dairy Hut, Feather Patch, Fly Fishing, Izba, Loft Storehouse, Nordic Granary, Hunting Cabin, Infirmary, Log Cabin, Sauna, Tailor Shop and Tannery, the Red Cottage, Purchase Patch, Small Windmill and Village Shop.
Then a few other random ones: RK Goats as Livestock, A8Moroccan Tea, Kid's 2019 Christmas Mod, as I mentioned the RealTimeAging mod, Better Season Reports, The Fountain Mod, Voeille's Lush & Green mod.
I also just noticed I have the CC Hot Crops mod installed although that should already be included in the MegaMod, not sure if that would cause errors though.
2 others I have but not sure are needed is the Flax Patch and the 1.0.7. Compatibility Patch.

Phew, quite a list, but I'm not the only one with this many mods installed right? :-\

Some of them I only use because I like a few of their buildings but could do without all the rest. I have no knowledge of modding though so I wouldn't know how to extract the ones I like if that's even possible.

Anyway, suggestions are welcome, I just wanna be able to play without having to restart all the time.

Offline theonlywanderer

  • Trader
  • ****
  • Posts: 217
Re: Compatability Question - Game Crashes
« Reply #1 on: January 04, 2020, 05:57:29 PM »
MM8 is huge all on it's own and not really a good idea using other mods with it.

I doubt anyone is going to be able to just say so and so mod is your problem.  All you can do is remove the mods one by one until you get a stable game or the reverse where you take away all the mods and add them one by one until it crashes.

Another option would be to go through the MM8 pdf file that lists all the included mods and pick out the specific ones you want and find all the stand alone versions of those mods and use those instead of the full MM8.

There really isn't an easy solution to this problem.

Offline tuggistar

  • Trader
  • ****
  • Posts: 190
Re: Compatability Question - Game Crashes
« Reply #2 on: January 04, 2020, 06:27:03 PM »
I have with MegaMod 8.01 and a bunch of mods is worth it. I recommend removing the mod The Fountain Mod and putting fountainlite instead. With the new limits I had a problem with this mods, after replacing on fountainlite no problem. And I advise you to put Crystal Cliffs Farm V102 forward and then The Pine Set V105 in the mod list and below MegaMod 8.01, so that with The Pine Set there were no problems. I have all of Necora's The Maritimes collection below MegaMod 8.01. With Tom Sawyer's mods too, there are no problems that come with his site.

Offline tuggistar

  • Trader
  • ****
  • Posts: 190
Re: Compatability Question - Game Crashes
« Reply #3 on: January 04, 2020, 06:43:32 PM »
Mods Feather Patch and Purchase Patch unfortunately have nothing to say. Mods Compatibility Patch, I do not know but with MegaMod 8.01 seems not needed, if all the other mods version 1.0.7.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 4414
Re: Compatability Question - Game Crashes
« Reply #4 on: January 04, 2020, 07:06:28 PM »
what is the last things you built? if it functioned to year 76,it should play. unless you built something different that is the conflict. this deep into a game issues are tough to narrow down.it could be you produced something different than before. changed a processor.  could be that a building from 1 of the mods you added acted different than the way CC coded it for the MM.

     does the crash happen at the same time every time you reload from the ast save point? try saving just before the crash. then chec each bannie to see what they are doing. or try going back to an older save point and run the game. it might play right past the crash.

Offline Mikkey

  • Newb
  • *
  • Posts: 8
Re: Compatability Question - Game Crashes
« Reply #5 on: January 05, 2020, 01:46:13 AM »
I have with MegaMod 8.01 and a bunch of mods is worth it. I recommend removing the mod The Fountain Mod and putting fountainlite instead. With the new limits I had a problem with this mods, after replacing on fountainlite no problem. And I advise you to put Crystal Cliffs Farm V102 forward and then The Pine Set V105 in the mod list and below MegaMod 8.01, so that with The Pine Set there were no problems. I have all of Necora's The Maritimes collection below MegaMod 8.01. With Tom Sawyer's mods too, there are no problems that come with his site.
Ok I'll try removing the fountain mod and replace it with lite. I did move Pine Set above MM a while ago, cause I noticed problems there. I think Crystal Farms is still somewhere below it, didn't realize there was more to this mod, I thought it was mainly just objects not doing much. Plus, I don't think I have used any objects from that set in my game yet. Only stuff from the Pine Set.

Is it possible to remove the fountain set, replace with lite, and still use the same save if I delete any objects I may have used from that set so far? probably not, right?

Mods Feather Patch and Purchase Patch unfortunately have nothing to say. Mods Compatibility Patch, I do not know but with MegaMod 8.01 seems not needed, if all the other mods version 1.0.7.
Do you mean they're outdated and not necessary? I do remember having an insane feather output, that's why I installed it.
The Purchase Patch was supposed to remove a problem with the trader, I've never noticed a problem but then again I don't pay much attention to trader in- and output.

what is the last things you built? if it functioned to year 76,it should play. unless you built something different that is the conflict. this deep into a game issues are tough to narrow down.it could be you produced something different than before. changed a processor.  could be that a building from 1 of the mods you added acted different than the way CC coded it for the MM.

     does the crash happen at the same time every time you reload from the ast save point? try saving just before the crash. then chec each bannie to see what they are doing. or try going back to an older save point and run the game. it might play right past the crash.
Well the last few times it pretty much crashed a few seconds after scrolling around in game. I think the last things I built were all objects included in MM. Like Kid's Education Center and the Zero House from the Medieval Grace Set. Then I went back to an auto save that did not have those yet. Then it seemed like the last things I touched was stuff from Discrepancy's Jetty Set.
I don't think it will let me check each bannie, it'll crash before that but yeah, maybe it's something I built a while ago and hasn't caused problems until there was some sort of interaction with a bannie?
This is what's so frustrating. Everything seems to be working fine for years in game, then all of a sudden the crashes happen while just moving the camera around. It never seems like I put down a specific building and then it crashes, it's always pretty random.


MM8 is huge all on it's own and not really a good idea using other mods with it. Another option would be to go through the MM8 pdf file that lists all the included mods and pick out the specific ones you want and find all the stand alone versions of those mods and use those instead of the full MM8.
There really isn't an easy solution to this problem.
Yeah, I started downloading the standalones yesterday but I'm afraid I will want so many of them that I end up with an insane list. Figuring out a working load order will be a difficult task I bet. And I will again have the problem that some things I want were put inside bigger sets, so the outcome will probably be a more complex version of MM  ;D
Ketchup's stuff for example. I don't think he offers updated standalones anymore, I would have to install his Editor's choice mod I believe and I don't know if that works well with Colonial Charter and other mods.

Also, would all the buildings behave the same as in MM if I downloaded seperately? The bakeries for example pretty much all create the same stuff in MM, very diverse food options. Did they meddle with that for MM or does each creator really have the same food output for that building? I don't really know how it works, I just don't want to end up with less options than MM offers.



So thanks for all the suggestions guys. I think I will first try what tuggistar said, replace fountain with the lite version and move crystal cliffs up in the list or maybe even remove it. I'll use a test game in debug mode and let it run for a few years.

If anyone has more ideas or encountered the same problem please let me know :)


Offline brads3

  • Banished Expert
  • *****
  • Posts: 4414
Re: Compatability Question - Game Crashes
« Reply #6 on: January 05, 2020, 08:25:29 AM »
when i said check each bannie to see wha they are doing,i ment wih the game paused. i agree it can be very tedious to try and find the issue. i do not think it is he mod order since the game played so many years. it can be tha you hit a limit to your computer handleing the calcutations internally.  most computers seem to hit this about 150 years. with so many mods,the MM has 100's inside it, you could be hitting this early.

    i do hope u tried this over a couple days. if an updater turned on or some other program it woud taKe memory. this could cause a crash. the same game woud play tomorrow that crashed today. or might play from an older save past the crash point. unless you can guess what mod is  causing any issues, you may want to start a new map. keep in mind the year you have crashed at and try to play farther. if you crash again at about the same year,then decide what to do next.

     the REC and CC can be played together. this does give different options. i do not use the MM, but i assume CC did not include the new wild animals of the RKEC. as you stated,it would be very time consuming to load each mod that is included in the MM and then adjust the mod order to get them all to function. i personally prefer adding mods instead of using the MM. it does give me more control how the mods interact so i can tweak things. my computer however does not have enuf power to handle the MM. i can use about 135 mods to a map.   

Offline Mikkey

  • Newb
  • *
  • Posts: 8
Re: Compatability Question - Game Crashes
« Reply #7 on: January 05, 2020, 10:19:37 AM »
it can be tha you hit a limit to your computer handleing the calcutations internally.  most computers seem to hit this about 150 years. with so many mods,the MM has 100's inside it, you could be hitting this early.

    i do hope u tried this over a couple days. if an updater turned on or some other program it woud taKe memory. this could cause a crash. the same game woud play tomorrow that crashed today. or might play from an older save past the crash point. unless you can guess what mod is  causing any issues, you may want to start a new map. keep in mind the year you have crashed at and try to play farther. if you crash again at about the same year,then decide what to do next.

     the REC and CC can be played together. this does give different options. i do not use the MM, but i assume CC did not include the new wild animals of the RKEC. as you stated,it would be very time consuming to load each mod that is included in the MM and then adjust the mod order to get them all to function. i personally prefer adding mods instead of using the MM. it does give me more control how the mods interact so i can tweak things. my computer however does not have enuf power to handle the MM. i can use about 135 mods to a map.   
Is that 135 mods including bigger ones that contain several or just individual ones? Because I don't think that's a lot at all.

Yes, I've played over several days. I hope this is not my pc being unable to handle the game (I have 16gb ram, CPU is Intel(R) Core(TM i7-7700, 3.60Ghz, graphics card is NVIDIA Geforce GTX 1060GB), surely it can't be that bad.

I used to be able to play way longer on my old computer, usually it would start lagging and occasionally crash at 1000pop. This was with a previous version of MM though.

I will delete a few mods and switch to fountain lite for now and see if that works better. Otherwise I guess I'll have to use them all individually and make significant cuts  :(

Offline theonlywanderer

  • Trader
  • ****
  • Posts: 217
Re: Compatability Question - Game Crashes
« Reply #8 on: January 05, 2020, 04:14:02 PM »
@Mikkey

Your PC is more than enough to handle this game.   With that said, the game doesn't seem to be efficiently done so it's always going to have speed issues on any PC once that magic population number is hit for each particular PC.

As for the feather output, no need to add a mod to deal with that.   Just add a trade port and set it to 9999 feathers.  Tell all the merchants to only bring stuff you need and set it to auto trade.   You can then just leave that trade port alone to do it's thing.

Personally, I don't get the need to have so many mods for one map.   CC is great on it's own and it's included with MM8 which makes MM8 that much better.   RKEC is great on it's on and so are the NORTH options.    Seems so much easier to just focus on certain key mods for any particular map in order to avoid such time consuming crash issues.  If diversity is what you want, than focus on more smaller maps with less mods.    Think of each smaller map as part of a bigger map.    Trying to make this game do to much is always going to be problematic.     Having large maps and trying to isolate villages of certain styles creates issues with this game since it wasn't meant for that style of game play.   Better to have smaller maps and create each style of village separately.   The speed will be better and also easier to manage mod wise.
« Last Edit: January 05, 2020, 04:34:23 PM by theonlywanderer »

Offline Mikkey

  • Newb
  • *
  • Posts: 8
Re: Compatability Question - Game Crashes
« Reply #9 on: January 09, 2020, 03:52:51 AM »
Okay I removed MM8 now and played around with RKEC plus CC 1.76 (it does not have the same houses as in MM8  :'( ) and a couple of other mods.
Had the same issue after even less years and bannies. I now blame it on Necora's Pine set. I suspect it has to do with some kind of interaction with the pine resources. I had it installed in the previous MM8 game together with the Flax Patch but there may still be something else going on. As soon as I had some of the resource buildings built in the new game it started crashing again. I will leave it installed for now, but will only touch its home and town service buildings and see how that goes, the pine cabins are just too cute to remove but unfortunately there is no standalone mod.

Thanks for all the suggestions, guys.

Edit: oh and @theonlywanderer: I know what you're saying but I like the diversity of all the different crops, foods, resources of all the mods. Putting just a limited number of them in a game is not that fun for me, I love the complexity of them all together.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 4414
Re: Compatability Question - Game Crashes
« Reply #10 on: January 09, 2020, 06:10:04 AM »
that is quite possable. with the RKEC, i found some tricks to get the pine to work. even then it restricts which start settings i can use. try moving the pine mod below the CC MM ,and in your case don't use the flax patch.that way the MM loads the spawned items and trees but you still have the buildings you like.

     you could have added most of the CC buildings to the RKEC by just adding the CC Journey below the RKEC. gives you the best of both worlds.

Offline Mikkey

  • Newb
  • *
  • Posts: 8
Re: Compatability Question - Game Crashes
« Reply #11 on: January 09, 2020, 02:07:02 PM »
that is quite possable. with the RKEC, i found some tricks to get the pine to work. even then it restricts which start settings i can use. try moving the pine mod below the CC MM ,and in your case don't use the flax patch.that way the MM loads the spawned items and trees but you still have the buildings you like.

     you could have added most of the CC buildings to the RKEC by just adding the CC Journey below the RKEC. gives you the best of both worlds.
Yeah, I threw out the flax patch, but still had to move it above RKEC to prevent it from crashing. No idea why, I will test it, if nothing works I'll remove the Pine mod :(

I've removed MM entirely and now use RKEC and below that CC Journey so I do have the same buildings (except for the houses that have less color options in CC).
Not gonna go back to MM for now cause I fell in love with RK's dock set, although I do prefer the old NMT buildings to the new ones. But until I learn how to mod or at least extract stuff I like, I can't have it all I guess  ;D

Offline brads3

  • Banished Expert
  • *****
  • Posts: 4414
Re: Compatability Question - Game Crashes
« Reply #12 on: January 09, 2020, 04:38:24 PM »
for some reason, you need the maritimes cliff's mod with the pine mod to work with the RKEC. i have it with the fora patch but no flax patch , all above the RKEC. like i said before some start settings do not work thou. medium starts do work fine. all map sizes work. not sure what colored buildings you are missing. KID made a colonial mod and so did PILGRIM. Necora's sherbrooke mod has some colorful houses too.

Offline galensgranny

  • Banished Expert
  • *****
  • Posts: 1017
Re: Compatability Question - Game Crashes
« Reply #13 on: January 10, 2020, 02:05:14 PM »
brad, I did not know about needing Necora's Maritimes Cliff along with the Pine mod to get the Pine mod to work with RKEC.  I must try that someday so I get the Pine Mod working again without crashing.
@Mikkey, you can still have Red's old NMT buildings at the same time as RKEC, if you mean his Medieval Town 2.04 at http://worldofbanished.com/index.php?action=downloads;sa=view;down=139    I use them both together.

Offline brads3

  • Banished Expert
  • *****
  • Posts: 4414
Re: Compatability Question - Game Crashes
« Reply #14 on: January 10, 2020, 02:44:30 PM »
granny another option is to use the pine mod below the RKEC.i do not rememeber if you stil need the cliffs mod then.