Welcome to World of Banished!

Main Menu

Need help with the ToolKit

Started by PlumSeed, January 24, 2023, 04:18:41 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi everyone,

sorry if this has already been discussed but I can't find an answer.

I decided to learn to mod but so far things aren't looking good. I installed the toolkit and copied the game files in bin/windata, ran the command line but nothing is compiled.

Visual Studio 2012 is installed and I already have DirectX12 so I can't install DirectX End User Runtime. I don't know if it's because of this.

I got this :

C:\>cd BanishedKit
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad0
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad1
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad2
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad3
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad4
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad5
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad6
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad7
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad8
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad9
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad10
C:\BanishedKit>bin\x64\Tools-x64.exe /build Dialog\Loading.rsc:gameLoad11
C:\BanishedKit>bin\x64\Tools-x64.exe /build Game\GlobalResources.rsc
C:\BanishedKit>bin\x64\Tools-x64.exe /build Game\MenuResources.rsc
C:\BanishedKit>bin\x64\Tools-x64.exe /build Game\GameResources.rsc
C:\BanishedKit>if not exist bin\WinData\Save\ md bin\WinData\Save\
C:\BanishedKit>copy resource\Save\*.sav bin\WinData\Save\
        4 fichier(s) copiĆ©(s).

And that's it.

Any help will be greatly appreciated.


Hi @brads3, thanks for your reply. I checked that section before posting but didn't find info.

Like I said, I have Visual C++ 2012 Redist installed (11.0.61030, is it the right version?).

I tried to install DirectX End User Runtime from the link provided on, but the installation automatically stop because it detect a version of DirectX more recent on my system. So I found DirectX Software Development Kit instead and installed it.

I also deactivated my antivirus to be sure but it doesn't change anything since when I run BuildResources.bat (in admin) resources aren't compile in bin/windata. It doesn't have errors nor crash.

When I run Application-x64-profile.exe I get the "not recognized as an internal or external command" error.


sorry, i am not a modder. did you check the shinning rock site for any info? hopefully a modder will check in soon.


yes, I downloaded the toolkit from this site and I followed the steps scrupulously but I must have done something wrong since it doesn't work. It's too bad  :(. But thanks again for your reply.


i am sorry i ve been away from this since long time. i ve got problem in window10 with it when i tried to reinstall. maybe it is not set to work on win10/11 ? i dont know.
> > > Support Mods Creation developments with Donations by Paypal  < < <
Click here to Donate by PayPal .


yeah, I begin to think so... unfortunately.

First, I don't think it's possible to install DirectX End User Runtime when there is Directx12 already installed and I don't think we can uninstall it (but I'm far from being an expert so I could be wrong). If I'm not wrong, Windows updates deals with DX12 on Win10.

Instead, I installed DirectX SDK. But I'm an idiot, I didn't know the installer just download unpacks files and you must find the dxsetup.exe in it and run that to install  ;D.

When I did it, I was able to compile but only with x32 and some folders was missing in bin/windata (3 or 4, I don't remember).

When I ran BuildExamples.bat, it only worked for apiary and it created a bin folder in example/building, nothing in windata.

Also, I'm still not able to run with the command prompt (in admin) Application-x32-profile (or Application-x64-profile), nothing happens.

I wonder if someone managed to install on Win10 without too much trouble.


I have Win10 and a LOT of installed extra components (mainly due to games and editors)
I have DirectX 12 and many Visual C++ Runtimes.

Here are links I used to get runtime components.

They do not modify your system's DirectX files!! Read on page.

For this game's Visual C++ runtimes, you should install these.

I think that should be enough. Those are the main packages.
Some games ask for other specific updates... not here

No, no , no. These files will not do anything harmful. They will be invisible until
they are needed. I think I have 14 Visual C++ packages from many years back.

Let's keep this open and take one problem at a time. :)


If Visual C++ refuses to install, you should be cool with already having the needed functions from a newer package.


Hi Kid, thanks for your help (all of you)  :)

Regarding DirectX End-User Runtime, I tried to installed it but the installation automatically stop because it detects a more recent version on my system. It's weird because like you said it isn't suppose to modify my system's dx files. If I need to uninstall something, I don't know what.

Instead, I installed Directx SDK.

For Visual C++ runtimes, I already have Visual C++ 2012 Redist (x64) and (x86) v. 11.0.61030. Are they the correct package?


The only answer to DirectX is that you have the runtime installed.
Yes, Visual C++ runtimes are the correct versions.

I understand you have checked everything. You have installed to C:\BanishedKit? Fine! I have it on D:\  :)

I never bothered to run the BuildResources.bat. I also didn't run the examples.
I did when I first set up the Kit, but next time I didn't. I always thought the instructions were awkward.

If you want you can get source files to put in your C:\BanishedKit and test if those work.
Just tell and I PM you a link.


thanks, I will take these source files.

I'm so confused with this kit... what's the difference between the files in the resource folder and those compiled by buildresources.bat in bin/windata? I feel like a toddler who is discovering the vast and overwhelming world of her backyard haha.


 ;D The files in the \resource\ folder are uncompiled (text-files)

Those can be changed. (never do that. Copy and rename to a new location!)

The files in bin\windata are compiled and can not even be edited. (finished game files)

Those files have to be copied to your Banished WinData folder to be visible in the game.

I have messed with my directory structure. It should not matter. It works either way.

I have my WinData  in D:\Banished\Win64\WinData  (I do not know if that is the default)

I leave for a while, but I will be back. There is a file in the message section for you.